A fix has been implemented and we are monitoring results.
Posted May 13, 2026 - 17:03 MDT
Identified
The issue has been identified and we are working on a fix.
Posted May 13, 2026 - 17:01 MDT
Investigating
We are currently experiencing degraded performance across the Smart Access application. Users may encounter slow load times, timeouts, or partial service disruptions.
Initial investigations indicate this is related to a broader issue affecting Google Cloud Platform (GCP) infrastructure. We are actively working with GCP and monitoring the situation closely to determine the scope and impact.