A fix has been implemented and we are monitoring to confirm the issue has been remediated.
Posted Apr 02, 2026 - 11:03 MDT
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 02, 2026 - 09:15 MDT
Investigating
Our data processing infrastructure is running behind which may affect data availability in the reporting tools. Newly created data will be retained, no data has been lost and the system should be caught up shortly. We appreciate your patience.
Posted Apr 02, 2026 - 06:08 MDT
This incident affects: Experience (Admin Console (Portal), Universal Application (mobile & browser-based)), Platform (Insights, API & Integrations), and Google Cloud Platform Google BigQuery.